Opened 11 years ago

Closed 11 years ago

#33 closed defect (fixed)

"Failed to setup location" problem

Reported by: Pete Jalajas Owned by: ben
Priority: major Milestone: 0.11
Component: bbackupd Version: 0.10
Keywords: Cc:

Description

From thread: http://lists.warhead.org.uk/pipermail/boxbackup/2007-July/003668.html (Client chris_general_1692; we also tried 1662, and got similar errors, albeit with slightly different Windows Service crashing behavior. We're not sure if there is something funky about the mapped shares [we don't think so, as we tried some very simple shares as well] or something with the Box Backup.)

I think that with ExtendedLogging = yes, Box Backup should report into the log the FULL PATH of each file or directory IMMEDIATELY BEFORE it works on it, to help diagnose problems when such files or directories cause failures.

Exceptions/errors, such as OSFileError for example, should report which file or directory had the problem, and what the problem is, something like "Not writeable".

(Should/Can? "Failed to setup location" report why it failed, or at least report the current values of some relevant variables?)

I'm setting this bug to major priority because it (needing the full path) is a recurring issue and would be so helpful as Box Backup works it's way from 0.10 to 1.0.

Thanks, Pete

Change History (1)

comment:1 Changed 11 years ago by chris

Milestone: 0.11
Resolution: fixed
Status: newclosed

Fixed with new logging framework and new LogAllFileAccess option. If you still have problems, let me know.

Note: See TracTickets for help on using tickets.