Opened 12 years ago

Closed 11 years ago

#34 closed defect (invalid)

Cipher EVPFinalFailure 5/6 with OpenSSL 0.9.7

Reported by: chris Owned by: chris
Priority: normal Milestone: 0.11
Component: bbackupd Version:
Keywords: openssl Cipher EVPFinalFailure 5/6 Cc:

Description

Date: Thu, 09 Aug 2007 23:20:26 +0200 From: "[ISO-8859-1] N�her M�rton" <[email protected]…> Reply-To: [email protected]… To: [email protected]… Subject: [Box Backup] boxbackup bug with openssl

[ The following text is in the "ISO-8859-1" character set. ] [ Your display is set for the "utf-8" character set. ] [ Some characters may be displayed incorrectly. ]

Hi!

I have a backup servers, and 5 other computers, to back them up. 4 of the 5 servers uses openssl-0.9.8, so as the backupserver, but 1 uses openssl-0.9.7. I was simply unable to sync with that client, but backup was really urgent, so i made some hack with nfs, but it is really not important.

Here are the extended logs of the client and server, hopefully you can use it to fix this problem. (### is commented out, that is fully qualified hostname and living ip address)

marton neher

Aug 9 21:30:20 veszely bbackupd[7734]: Incoming connection from local (UNIX socket) Aug 9 21:30:20 veszely bbackupd[7734]: Connection from command socket Aug 9 21:30:20 veszely bbackupd[7734]: Beginning scan of local files Aug 9 21:30:20 veszely bbackupd[7734]: Opening connection to server #############... Aug 9 21:30:20 veszely bbackupd[7734]: Send Version(0x1) Aug 9 21:30:20 veszely bbackupd[7734]: Receive Version(0x1) Aug 9 21:30:20 veszely bbackupd[7734]: Send Login(0xa002,0x0) Aug 9 21:30:20 veszely bbackupd[7734]: Receive LoginConfirmed?(0x4374948d68040,0x336ce,0x15e00000,0x19000000) Aug 9 21:30:20 veszely bbackupd[7734]: Connection made, login successful Aug 9 21:30:20 veszely bbackupd[7734]: Send ListDirectory?(0x1,0x2,0xc,false) Aug 9 21:30:20 veszely bbackupd[7734]: Receive Success(0x1) Aug 9 21:30:20 veszely bbackupd[7734]: Receiving stream, size 96 Aug 9 21:30:20 veszely bbackupd[7734]: Send SetClientStoreMarker?(0x4374949f86b00) Aug 9 21:30:20 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope routines:EVP_DecryptFinal:bad decrypt Aug 9 21:30:20 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope routines:EVP_DecryptFinal:bad decrypt Aug 9 21:30:20 veszely bbackupd[7734]: Exception caught (Cipher EVPFinalFailure 5/6), reset state and waiting to retry... Aug 9 21:30:30 veszely bbackupd[7734]: File statistics: total file size uploaded 0, bytes already on server 0, encoded size 0 Aug 9 21:31:55 veszely bbackupd[7734]: Beginning scan of local files Aug 9 21:31:55 veszely bbackupd[7734]: Opening connection to server backup.lanten.hu... Aug 9 21:31:55 veszely bbackupd[7734]: Send Version(0x1) Aug 9 21:31:55 veszely bbackupd[7734]: Receive Version(0x1) Aug 9 21:31:55 veszely bbackupd[7734]: Send Login(0xa002,0x0) Aug 9 21:31:55 veszely bbackupd[7734]: Receive LoginConfirmed?(0x4374949f86b00,0x336ce,0x15e00000,0x19000000) Aug 9 21:31:55 veszely bbackupd[7734]: Connection made, login successful Aug 9 21:31:55 veszely bbackupd[7734]: Send ListDirectory?(0x1,0x2,0xc,false) Aug 9 21:31:55 veszely bbackupd[7734]: Receive Success(0x1) Aug 9 21:31:55 veszely bbackupd[7734]: Receiving stream, size 96 Aug 9 21:31:55 veszely bbackupd[7734]: Send SetClientStoreMarker?(0x437494fa200c0) Aug 9 21:31:55 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope routines:EVP_DecryptFinal:bad decrypt Aug 9 21:31:55 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope routines:EVP_DecryptFinal:bad decrypt Aug 9 21:31:55 veszely bbackupd[7734]: Exception caught (Cipher EVPFinalFailure 5/6), reset state and waiting to retry... Aug 9 21:32:05 veszely bbackupd[7734]: File statistics: total file size uploaded 0, bytes already on server 0, encoded size 0

Aug 9 21:30:27 selenyi bbstored[13199]: Incoming connection from ###.###.###.### port 47990 (handling in child 11480) Aug 9 21:30:28 selenyi bbstored[11480]: Certificate CN: BACKUP-a002 Aug 9 21:30:28 selenyi bbstored[11480]: Receive Version(0x1) Aug 9 21:30:28 selenyi bbstored[11480]: Receive Version(0x1) Aug 9 21:30:28 selenyi bbstored[11480]: Send Version(0x1) Aug 9 21:30:28 selenyi bbstored[11480]: Send Version(0x1) Aug 9 21:30:28 selenyi bbstored[11480]: Receive Login(0xa002,0x0) Aug 9 21:30:28 selenyi bbstored[11480]: Receive Login(0xa002,0x0) Aug 9 21:30:28 selenyi bbstored[11480]: Login: Client ID 0000A002, Read/Write? Aug 9 21:30:28 selenyi bbstored[11480]: Send LoginConfirmed?(0x4374948d68040,0x336ce,0x15e00000,0x19000000) Aug 9 21:30:28 selenyi bbstored[11480]: Send LoginConfirmed?(0x4374948d68040,0x336ce,0x15e00000,0x19000000) Aug 9 21:30:28 selenyi bbstored[11480]: Receive ListDirectory?(0x1,0x2,0xc,false) Aug 9 21:30:28 selenyi bbstored[11480]: Receive ListDirectory?(0x1,0x2,0xc,false) Aug 9 21:30:28 selenyi bbstored[11480]: Send Success(0x1) Aug 9 21:30:28 selenyi bbstored[11480]: Send Success(0x1) Aug 9 21:30:28 selenyi bbstored[11480]: Sending stream, size 96 Aug 9 21:30:28 selenyi bbstored[11480]: Receive SetClientStoreMarker?(0x4374949f86b00) Aug 9 21:30:28 selenyi bbstored[11480]: Receive SetClientStoreMarker?(0x4374949f86b00) Aug 9 21:30:28 selenyi bbstored[11480]: Send Success(0x4374949f86b00) Aug 9 21:30:28 selenyi bbstored[11480]: Send Success(0x4374949f86b00) Aug 9 21:30:28 selenyi bbstored[11480]: Connection statistics for BACKUP-a002: IN=97 OUT=220 TOTAL=317 Aug 9 21:30:28 selenyi bbstored[11480]: in server child, exception Connection Protocol_Timeout (Probably a network issue between client and server.) (7/41) -- terminating child

Change History (3)

comment:1 Changed 12 years ago by chris

Repasting logs:

Aug  9 21:30:20 veszely bbackupd[7734]: Incoming connection from local (UNIX socket)
Aug  9 21:30:20 veszely bbackupd[7734]: Connection from command socket
Aug  9 21:30:20 veszely bbackupd[7734]: Beginning scan of local files
Aug  9 21:30:20 veszely bbackupd[7734]: Opening connection to server #############...
Aug  9 21:30:20 veszely bbackupd[7734]: Send Version(0x1)
Aug  9 21:30:20 veszely bbackupd[7734]: Receive Version(0x1)
Aug  9 21:30:20 veszely bbackupd[7734]: Send Login(0xa002,0x0)
Aug  9 21:30:20 veszely bbackupd[7734]: Receive
LoginConfirmed(0x4374948d68040,0x336ce,0x15e00000,0x19000000)
Aug  9 21:30:20 veszely bbackupd[7734]: Connection made, login successful
Aug  9 21:30:20 veszely bbackupd[7734]: Send ListDirectory(0x1,0x2,0xc,false)
Aug  9 21:30:20 veszely bbackupd[7734]: Receive Success(0x1)
Aug  9 21:30:20 veszely bbackupd[7734]: Receiving stream, size 96
Aug  9 21:30:20 veszely bbackupd[7734]: Send SetClientStoreMarker(0x4374949f86b00)
Aug  9 21:30:20 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope
routines:EVP_DecryptFinal:bad decrypt
Aug  9 21:30:20 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope
routines:EVP_DecryptFinal:bad decrypt
Aug  9 21:30:20 veszely bbackupd[7734]: Exception caught (Cipher EVPFinalFailure 5/6), reset state and
waiting to retry...
Aug  9 21:30:30 veszely bbackupd[7734]: File statistics: total file size uploaded 0, bytes already on
server 0, encoded size 0
Aug  9 21:31:55 veszely bbackupd[7734]: Beginning scan of local files
Aug  9 21:31:55 veszely bbackupd[7734]: Opening connection to server backup.lanten.hu...
Aug  9 21:31:55 veszely bbackupd[7734]: Send Version(0x1)
Aug  9 21:31:55 veszely bbackupd[7734]: Receive Version(0x1)
Aug  9 21:31:55 veszely bbackupd[7734]: Send Login(0xa002,0x0)
Aug  9 21:31:55 veszely bbackupd[7734]: Receive
LoginConfirmed(0x4374949f86b00,0x336ce,0x15e00000,0x19000000)
Aug  9 21:31:55 veszely bbackupd[7734]: Connection made, login successful
Aug  9 21:31:55 veszely bbackupd[7734]: Send ListDirectory(0x1,0x2,0xc,false)
Aug  9 21:31:55 veszely bbackupd[7734]: Receive Success(0x1)
Aug  9 21:31:55 veszely bbackupd[7734]: Receiving stream, size 96
Aug  9 21:31:55 veszely bbackupd[7734]: Send SetClientStoreMarker(0x437494fa200c0)
Aug  9 21:31:55 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope
routines:EVP_DecryptFinal:bad decrypt
Aug  9 21:31:55 veszely bbackupd[7734]: SSL err during Read: error:06065064:digital envelope
routines:EVP_DecryptFinal:bad decrypt
Aug  9 21:31:55 veszely bbackupd[7734]: Exception caught (Cipher EVPFinalFailure 5/6), reset state and
waiting to retry...
Aug  9 21:32:05 veszely bbackupd[7734]: File statistics: total file size uploaded 0, bytes already on
server 0, encoded size 0
Aug  9 21:30:27 selenyi bbstored[13199]: Incoming connection from ###.###.###.### port 47990 (handling
in child 11480)
Aug  9 21:30:28 selenyi bbstored[11480]: Certificate CN: BACKUP-a002
Aug  9 21:30:28 selenyi bbstored[11480]: Receive Version(0x1)
Aug  9 21:30:28 selenyi bbstored[11480]: Receive Version(0x1)
Aug  9 21:30:28 selenyi bbstored[11480]: Send Version(0x1)
Aug  9 21:30:28 selenyi bbstored[11480]: Send Version(0x1)
Aug  9 21:30:28 selenyi bbstored[11480]: Receive Login(0xa002,0x0)
Aug  9 21:30:28 selenyi bbstored[11480]: Receive Login(0xa002,0x0)
Aug  9 21:30:28 selenyi bbstored[11480]: Login: Client ID 0000A002, Read/Write
Aug  9 21:30:28 selenyi bbstored[11480]: Send
LoginConfirmed(0x4374948d68040,0x336ce,0x15e00000,0x19000000)
Aug  9 21:30:28 selenyi bbstored[11480]: Send
LoginConfirmed(0x4374948d68040,0x336ce,0x15e00000,0x19000000)
Aug  9 21:30:28 selenyi bbstored[11480]: Receive ListDirectory(0x1,0x2,0xc,false)
Aug  9 21:30:28 selenyi bbstored[11480]: Receive ListDirectory(0x1,0x2,0xc,false)
Aug  9 21:30:28 selenyi bbstored[11480]: Send Success(0x1)
Aug  9 21:30:28 selenyi bbstored[11480]: Send Success(0x1)
Aug  9 21:30:28 selenyi bbstored[11480]: Sending stream, size 96
Aug  9 21:30:28 selenyi bbstored[11480]: Receive SetClientStoreMarker(0x4374949f86b00)
Aug  9 21:30:28 selenyi bbstored[11480]: Receive SetClientStoreMarker(0x4374949f86b00)
Aug  9 21:30:28 selenyi bbstored[11480]: Send Success(0x4374949f86b00)
Aug  9 21:30:28 selenyi bbstored[11480]: Send Success(0x4374949f86b00)
Aug  9 21:30:28 selenyi bbstored[11480]: Connection statistics for BACKUP-a002: IN=97 OUT=220
TOTAL=317
Aug  9 21:30:28 selenyi bbstored[11480]: in server child, exception Connection Protocol_Timeout
(Probably a network issue between client and server.) (7/41) -- terminating child

comment:2 Changed 12 years ago by chris

Owner: changed from ben to chris
Status: newassigned

Probably the same bug as #21. Awaiting feedback.

comment:3 Changed 11 years ago by chris

Resolution: invalid
Status: assignedclosed

Not enough info to fix. Closing ticket due to lack of feedback.

Note: See TracTickets for help on using tickets.